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WHAT IS IDRAW PEN PLOTTING
Alright, so let’s talk about iDraw—a super cool tool for plotting art of all
kinds, portraits, or even “handwriting” multiple cards in the same style. It’s
a pretty versatile gadget that lets you bring your digital designs to life with
a pen, adding a more organic and artistic feel to your prints.
The iDraw is a pen plotter tool. Pen plotters are an old technology,
providing computer-controlled graphics in an era before inkjet printers.
Lately, they’ve enjoyed a bit of a renaissance as a media curio, and as an
artistic tool that sits at the intersection of digital design and analog
execution. Plotters can execute highly precise images (think maps, vector
graphics, and tessellations) with conventional media (pens, markets, even
paint brushes if you plan your plot carefully). They can also be used to
precisely duplicate signatures, cursive, or other organic forms, so long as
they’re rendered as SVG files.
So, how does it work? The iDraw uses two mechanical arms to move a pen
across the paper, following the path you’ve programmed. The good news is
that you can easily control it with Inkscape, a free, open-source graphic
design software. If you’re on Windows or Linux, Inkscape has built-in
support for iDraw, so you’re good to go. If you’re using a Mac, there’s a
little extra setup involved, but don’t worry, we've got you covered!
Now, I won’t lie—it can be a bit tricky to set up at first, and it might seem a
little intimidating. But once you get the hang of it, not only will you have
learned a new skill, but you’ll also have an awesome way to create art that
feels a bit more personal and handmade.
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DOWNLOADING INKSCAPE
First things first, you’ll need to get Inkscape installed. Head over to this link:
https://inkscape.org/release/inkscape-1.3.2/ and follow the instructions for
your operating system.
If you’re on a Mac, there’s a bit of extra software you’ll need to install to get
iDraw up and running. This guide will walk you through it: https://github.
com/WCHSoftGroup/ch34xser_macos. For Windows and Linux users,
you’re all set right out of the box!
Basically, to set up the iDraw on your Mac, you need to first install the right
USB-to-Serial driver. This is because the iDraw uses a specific chip to
communicate with your computer, and MacOS needs a little help
recognizing it. The guide up above is helpful, but it might be a bit difficult
to understand at first—that's why we’re here to help out!
Downloading the Driver
First, you need to download the driver from this link below. Once
downloaded, unzip the file to get ready for instillation.
http://www.wch.cn/downloads/CH34XSER_MAC_ZIP.html
Installing the Driver
Depending on your macOS version, the installation process is a little
different:
For macOS 11.0 (Big Sur) and above: If your Mac doesn’t support Rosetta
(which helps run older software on newer Macs), you’ll need to install the
driver in a .dmg format. Simply double-click the .dmg file, drag the
“CH34xVCPDriver” to your Applications folder, then open it from
LaunchPad and click “Install.”
For earlier versions of macOS or if your Mac supports Rosetta: You’ll be
installing the driver using a .pkg file. Just click on the .pkg file and follow
the installation prompts. If you’re on macOS 11.0 or later, you might need
to open the CH34xVCPDriver app from LaunchPad and click “Install” to
complete the setup.
Check Installation
After installing, plug in your iDraw, and check if it’s working:
Open “System Report” from the Apple menu and click on “Hardware” >
“USB.” Look for a device with “Vendor ID: [0x1a86]”—this means your Mac
recognizes the iDraw.
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Open Terminal (Applications > Utilities), and type ls /dev/tty*. You should
see something like tty.wchusbserialx, where “x” is the device number. This
confirms the driver is installed correctly.
Final Checks
macOS High Sierra (10.13) and later introduced a security feature that
requires user approval before loading new drivers. If you’re prompted, go
to “System Preferences” > “Security & Privacy” and click “Allow” to enable
the driver.
And that’s it! With the driver installed and your iDraw recognized, you’re
ready to start creating with your pen plotter.



QUICK INKSCAPE TUTORIAL
So, you’ve got this awesome open-source and totally free software and you
want to try it out—so let’s look a bit closer at Inkscape itself.
When you first open Inkscape, it might feel overwhelming to see all the
buttons and options, but don’t worry—we'll break it down for you.
• Toolbox (on the left): This is where you’ll find all your drawing tools. Want

to draw a rectangle, circle, or straight line? This is where you’ll start. Just
click on the tool you want and start drawing on the canvas.

• Canvas (in the center): The big white space in the middle is your
canvas—this is where your masterpiece comes to life. You can zoom in
and out, move around, and resize your canvas to fit your needs.

• Colour Palette (at the bottom): At the bottom of the screen, you’ll see a
bar with lots of colours. This is your colour palette, where you can
choose colours for your shapes, lines, and text. Just click on a colour, and
it’ll apply to whatever you’re working on.

• Menus and Toolbars (at the top): At the top of the screen, you’ll find
menus and toolbars with more options. These let you do things like
adjust the size and position of objects, add effects, and manage layers.

Image Description: a screenshot of Inkscape, showcasing a blank page in the middle,
and tool bars and menus all around.



8

Basic Tools to Get You Started:
• Selection Tool (the arrow): This is your go-to tool for moving things

around, resizing, and rotating. Just click on any object, and you can drag
it, stretch it, or spin it.

• Shape Tools (rectangle, circle, etc.): These tools let you create basic
shapes with just a click and drag. Perfect for building the foundation of
your design.

• Pen and Pencil Tools: Want to draw freehand? The pen and pencil tools
let you create custom shapes and lines, just like sketching on paper.

• Text Tool (the letter “A”): Need to add some text? The text tool is there
to help you type out anything you want, from simple labels to stylish
typography.

• Fill and Stroke: This is where you control the colors and outlines of your
shapes. You can choose to fill an object with color, give it an outline
(stroke), or do both.

Layers, How To Keep Things Organized:
As you start adding more elements to your design, things can get a bit
cluttered. That’s where layers come in handy. Think of layers like transparent
sheets stacked on top of each other—you can organize different parts of
your design on different layers, making it easier to manage and edit.

Saving, Exporting, and SVGs:
Once you’ve created something you’re happy with, you can save your work
as an SVG file, which is perfect for resizing and plotting with the iDraw. You
can also export your design as a PNG or other file formats if you want to
use it for something else.
Now, we’ll talk more about SVGs in more detail later, but for now, here’s a
quick guide on how to save your Inkscape work as an SVG:
1. Go to the “File” menu and select “Save As…”
2. In the file format dropdown, choose “Inkscape SVG” or “Plain SVG.” The

difference between the two is that "Inkscape SVG" includes some extra
information specific to Inkscape, while "Plain SVG" is more universally
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compatible. For pen plotting, either should work fine, but "Plain SVG" is
often the safer bet if you plan to use your file in other programs.

3. Choose where you want to save your file, give it a name, and hit “Save.”
If you need your design in a different format, like PNG or PDF, Inkscape
also has you covered. Just go to the “File” menu and select “Export PNG
Image…” or “Save As…” and choose your desired format. But remember,
when it comes to pen plotting, SVG is your best friend.

Experiment and Explore:
The best way to learn Inkscape is to play around with it. Try out different
tools, experiment with shapes and colors, and don’t be afraid to make
mistakes. There’s a lot you can do with Inkscape, and the more you explore,
the more confident you’ll become.
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SETTING UP THE iDRAW
Now that Inkscape’s ready and you’ve got a handle on some basics, it’s
time to set up your iDraw. The iDraw is a plotting surface with two
mechanical arms—one that moves along the X-axis (left to right) and one
along the Y-axis (up and down the page). By default, in the lab the iDraw
should be plugged into the lab computer through the USB port, if you want
to use it through your personal computer please go right ahead, just make
sure to plug it back in afterwards.

Image Description: A photo of the iDraw 2.0 pen plotter, both motor arms are visible,
but the photo is focused on the drawing arm where the pen is affixed. A single sheet
of paper is attached to the drawing surface via rare earth magnets.

You’ll want to start by finding some paper that’s right for your project. The
iDraw 2.0 has a plotting surface of 210 by 297mm, or A4 size paper. For us
Canadians, that puts the closest size as P5 type paper, which is 140 by
215mm, giving you some wiggle room when printing. I’d suggest starting
with some scrap paper first to test things out before you go for the good
stuff.
The iDraw’s surface has strong magnets to hold your paper in place during
printing, so make sure it’s secured before you turn it on and move on to the
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next step.

Image Description: An overhead view of the iDraw 2.0 pen plotter drawing surface
without any paper on it so that the grid is visible.

Plotting the Pen:
The first step is to decide what type of drawing or writing utensil you will be
using for your piece. This could be a pen, marker, pencil, or any tool that
fits within the plotter’s clamp. Make sure it's the right size for the clamp –
not too thick or too thin. The clamp is the part of the plotter that holds the
pen. On the iDraw 2.0, there’s usually a small knob or screw you need to
loosen. Turn it counterclockwise (to the left) to open the clamp. Don’t take
the screw out completely—just loosen it enough so that you can slide your
drawing utensil in.



Image Description: A close up
of the pen holder part of the
iDraw 2.0, the screw for
holding the writing utensil in
place is shown along with a
sample blue pen.

Gently slide your pen or
marker into the clamp.
Make sure it’s positioned
straight and is pointing
downward. You want to
ensure the tip of the pen
is just touching or
hovering slightly above
the paper when the
plotter is in its resting
position. This will help in
getting a clean, accurate
drawing without too much
pressure. You might need
to play around a bit to get
the pen at the perfect
height. Too high, and it
won’t draw; too low, and it
might drag too heavily on the paper. A good rule of thumb is to make sure
the pen tip is just brushing against the surface of the paper.
Once you’re happy with the pen’s position, tighten the clamp back up by
turning the screw or knob clockwise (to the right). Make sure it’s snug but
not overly tight—you don’t want to damage the pen or the clamp. Before
starting your actual drawing, do a quick test run. You can do this by running
a test plot or a simple line to see if the pen is drawing properly. If it looks
good, you’re all set! If not, adjust the height or the tightness of the clamp
until you're satisfied.

12
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Utensil Selection:
Artist’s Pen

What it is: Artist's pens, like those from brands like Micron or Staedtler,
are fine-tipped pens often used for detailed line work and
illustrations.

Considerations: These pens are fantastic for getting crisp, clean lines,
especially if you’re doing intricate designs or technical drawings.
However, because they have delicate tips, you’ll want to be careful not
to press too hard with the plotter. Adjust the pen height carefully to
ensure just a light touch on the paper. Also, make sure the ink flow is
smooth – if it’s running out, the plotter might create broken lines.

Ballpoint Pen
What it is: The classic everyday pen. Ballpoint pens are versatile and
come in various tip sizes, from fine to bold.

Considerations: Ballpoint pens are great for plotters because they
have a more durable tip and can handle more pressure without
breaking. They’re also less likely to smudge compared to some other
pens. However, they might not be as vibrant as other options like
Sharpies or artist’s pens. Be sure to check the flow and make sure the
pen isn’t too thick for your design if you want fine details.

Pencil
What it is: Good old pencils are perfect for sketches or designs where
you might want a softer look or the option to erase.

Considerations: Pencils offer a unique advantage because you can
shade and create different textures with them, but they require careful
calibration. The pressure needs to be just right – too much, and the
plotter might break the lead or make overly dark lines; too little, and
the lines may not show up well. You also need to ensure the pencil is
well-sharpened for consistent line quality. Be aware that graphite can
smudge easily, so handle your final design with care!

Sharpie
What it is: Sharpies are permanent markers known for their bold and
vibrant ink. They come in a variety of tip sizes, including fine and ultra-
fine points.

Considerations: Sharpies are excellent for making bold, eye-catching
designs. The ink dries quickly and is quite permanent, which is great
for durability but also means you need to be careful with placement –
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once it’s on the paper, it’s not coming off! Also, Sharpies can bleed
through thinner paper, so use thicker stock to prevent this. Keep in
mind that the strong odour from the ink might require good
ventilation.
◦ On the topic of ventilation, our lab can be quite stuffy! If you’re
working with sharpies we recommend having a window open, get
some fresh air!
◦ Just to be safe, you should also use a scrap piece of paper
underneath even the thicker stock to ensure that the drawing surface
does not get damaged by the sharpies used.

Gel Pen
What it is: Gel pens are known for their smooth, vibrant ink that flows
more freely than standard ballpoint pens. They come in a wide range
of colours, including metallics and neons, and can have various tip
sizes.

Considerations: Gel pens are fantastic for adding bright, colorful
details to your designs. The ink is usually quite vivid and opaque,
which makes it great for drawing on both white and dark papers.
However, there are a few things to watch out for:
◦ Gel pens can be prone to smudging because the ink takes longer
to dry than that of a ballpoint pen. When using them in the plotter,
make sure to give enough time between strokes or layers for the ink to
dry. Also, the ink flow can sometimes be inconsistent, especially if the
pen is running low or has been stored improperly. Make sure to use a
gel pen with good, consistent ink flow for the best results.
◦ Because gel ink can be wetter than other inks, it’s best to use a
thicker, non-absorbent paper to prevent the ink from bleeding
through. Smooth paper surfaces also work better as they help the gel
ink glide more evenly.
▪ This is another option where we recommend a scrap piece of
paper underneath the print!
◦ Gel pens often have finer tips than markers, but not as fine as
artist's pens. This makes them great for medium-detail work. Be
cautious with very fine or detailed drawings, as any variation in the
pen’s ink flow might affect the precision.

Highlighter
What it is: Highlighters are markers with translucent, fluorescent ink
designed to highlight text without obscuring it. They come in various
tip shapes, typically with a chisel edge, which can produce both broad
and fine lines.

Considerations: Highlighters can add a unique, bright, and attention-
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grabbing effect to your designs. They’re great for filling large areas
with bright colours or creating a glowing effect, but they also come
with their own set of challenges:
◦ Highlighters tend to have wetter ink that can bleed through
thinner paper, so it’s essential to use a thicker paper to avoid
unwanted bleed-through. Also, since the ink is translucent, the effect
can vary depending on the type of paper used. Darker papers might
not show the color as vividly as white or lighter papers.
◦ Our last one where we suggest, nay, insist, upon a protective
layer underneath the good print.
◦ Because the ink is designed to be semi-transparent, it might not
be ideal for detailed work where precise lines are crucial. Instead,
highlighters are best used for broader strokes or adding subtle
backgrounds and effects.
◦ The chisel tip common to highlighters can be a bit tricky to
control with a pen plotter, especially for fine details. The plotter might
have difficulty applying the correct pressure to achieve consistent
lines, especially for smaller or more intricate designs. Consider using
highlighters for bold, graphic effects or larger shapes rather than
detailed illustrations.
◦ Just like with gel pens, the wetness of the ink means you should
be careful to let the ink dry fully between strokes, or it may smudge.
Also, when the plotter crosses over previously highlighted areas, the
ink can smear if it's still wet, so consider the design's sequence and
plotting path.
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TESTING AND TROUBLESHOOTING THE iDRAW
Once you’ve got your paper set up and the iDraw connected to your
computer, it’s time to test everything out. Here’s how you do it:
1. Open Inkscape and go to the “Extensions” menu.
2. Scroll down to “iDraw 2.0 Control” and click on it.
3. In the setup tab, you can run some basic tests to make sure everything’s

working. Start by toggling the pen between UP and DOWN (on the Z-
axis) and hit “Apply.” You should see the pen move up or down—if it
does, you’re connected properly!

Now, here’s where you might need to do a bit of troubleshooting. Use the
UP and DOWN toggle to adjust the distance between the pen and the
paper. When the pen is UP, it should hover above the paper, and when it’s
DOWN, it should make a dot on the paper.

Make sure your iDraw is set to “move to the home corner” (the bottom-left
of the plotting surface). This ensures that when you start a print, the pen
begins in the right spot, so your design doesn’t end up off-center or
cropped in a weird way.

If you are more of a visual learner, this YouTube video does a good job of
walking you through the process: https://www.youtube.com/watch?
v=tphcpTOt0PE
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SVG FILES—WHERE TO GET, WHY DO WE LOVE THEM
So, let’s talk more about SVG files. SVG stands for Scalable Vector
Graphics, and they’re awesome for pen plotting because they don’t use
pixels. Instead, they’re made up of mathematical formulas that keep
everything looking sharp, no matter how much you resize them.

Image Description: an image of our director’s cat put through Squigglecam and
printed on the iDraw, she watches over the iDraw and lab computer from her spot on
the wall.

Now, while you can print directly from Inkscape, it’s not the most intuitive
software to work with. That’s where downloadable SVG files come in handy.
These files can be found all over the web, and you can even create your
own in software like Photoshop. Here are a few great resources to check
out:
Squigglecam: A super easy-to-use site that converts pictures (or webcam
images) into squiggles, perfect for pen plotting. It auto-downloads as an
SVG file. Check it out here:

https://msurguy.github.io/SquiggleCam/
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Plotterfun: Similar to Squigglecam but with more settings and styles to
play with. Find it here:

https://grbl-plotter.de/plotterfun/
UJI: This one’s a bit more experimental. It has a bunch of toggles and
switches to generate minimalist art. Play around and see what you can
come up with:

https://doersino.github.io/uji/
Drawingbots.net: A massive collection of tools and converters specifically
designed for drawing bots like the iDraw. Explore it here:

https://drawingbots.net/knowledge/tools
P5.JS: An open source JavaScript Library where you can use code to
generate all types of images, with a little bit of help from GitHub and some
determination, you can use this to easily produce customizable and auto-
downloadable SVGs. It may be a lot, but it’s always worth learning
something new:

https://p5js.org/
In the thrilling sequel to this breathtaking guide, we outline the steps
needed to get a handle on JavaScript and how to use p5 to produce SVGs
and generative art! Please stay tuned, as we are always working on
something new.
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PRINTING WITH THE IDRAW
Alright, once you’ve got your SVG file ready to go, you’ll need to convert it
to a path before printing. Here’s how you do it:
1. Select the object you want to print in Inkscape.
2. Go to the “Path” tab and select “Object to Path.” This locks the object

in place and ensures it can’t be edited further. You’ll need to do this for
any textboxes you’re printing too.

3. Next, go back to the Extensions tab and reopen the iDraw 2.0 control
window. Select “Plot,” and you’ll have the option to print multiple copies
if you need to, though 1 is the default.

Next, go back to the Extensions tab and reopen the iDraw 2.0 control
window. Select “Plot,” and you’ll have the option to print multiple copies if
you need to, though 1 is the default.
Before you hit “Apply,” make sure the pen is in the “home” position
(bottom-left corner). It should move there automatically, but it’s always a
good idea to double-check before starting the print.
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Image Description: a random SVG file printed on the iDraw using Inkscape.

Once you’re ready, click “Apply,” and the iDraw will get to work. If
something goes wrong, you can hit “pause” on the iDraw itself, which will
also pop up a window in Inkscape letting you know it detected a stop.
One last thing—don’t close Inkscape until the iDraw is completely finished
with the print or until you’ve manually stopped it. Otherwise it can cause
the entire computer to crash, which is not the desired outcome!
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SOLAR PRINTING
Imagine combining the precision and creativity of your iDraw pen plotter
with the natural, renewable energy of the sun. By powering your plotter
with solar panels, you’re not just making art—you’re embracing
sustainability and reducing your environmental impact. Solar-powered
printing allows you to bring your designs to life without relying on the
traditional electrical grid, making it a perfect match for off-grid projects,
eco-conscious creators, or anyone looking to minimize their energy
footprint while maintaining and embracing their creativity.
But beyond just being green, printing with solar energy can be a smart
choice for efficiency. Solar panels produce a steady stream of clean energy,
and by connecting them to your pen plotter, you’re tapping into a virtually
unlimited resource. Plus, solar power opens up creative possibilities—
imagine setting up a mobile printing station outdoors, where your plotter
runs directly from the energy it collects. This self-sufficiency is both
empowering and inspiring!
As with any solar-powered device, it’s important to understand how to
manage your energy consumption to ensure your plotter runs smoothly. By
optimizing your designs and knowing how much power you’re using, you
can make the most out of your solar setup. Ready to dive in? Let’s look at
how you can maximize energy efficiency by harnessing the sheer raw power
of the sun!

SIMPLIFYING DESIGNS FOR EASIER PRINTING
Working with solar power is rewarding, but it comes with its own share of
challenges! One of the best first steps when solar-powering your iDraw is to
make sure that any design is plotter-friendly and energy-efficient!
Use Fewer Lines: When you’re creating designs, try to reduce the number
of lines the plotter has to draw. Instead of intricate patterns, go for clean,
minimalistic shapes. Think about:
• Simple Geometric Shapes: Stick to basic shapes like circles, squares, and

triangles.
• Minimalist Patterns: Avoid highly detailed, complex patterns that would

take a long time for the plotter to process and print.
Optimize Line Path: The pen plotter uses energy each time it lifts the pen
and moves to a new position. If you plan your design so that the pen can
follow a continuous path without lifting too often, you’ll save energy. Here’s
how:



22

• Combine Shapes: Group parts of your design that can be drawn in one
continuous movement.

• Avoid Pen Lifting: Whenever possible, design paths that flow smoothly
from one section to another.

Reduce the Size of Designs: Large designs take longer to plot, which
means the plotter will use more energy. By shrinking your designs to a
manageable size, you cut down on plotting time and power usage.
Limit Shading and Fills: Solid fills or dense shading can take up a lot of
time and energy because the plotter will have to go over the same area
repeatedly. Instead, use:
• Hatching: Simple cross-hatching or spaced lines to suggest shading

without filling the entire area.
• Outline-Only: For many designs, just drawing the outline can look stylish

and save energy.
Optimize Line Thickness: Thicker lines are better for pen plotters because
they require fewer passes. Stick with lines that are bold enough to be
legible but don’t go overboard with super fine details.
Choose Simple Fonts: If you’re adding text, choose fonts that are bold and
easy to draw, like sans-serif fonts. Avoid anything too elaborate or with a lot
of curves.
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BRING IN THE SOLAR MATH
No volt reader? No problem! Switching to solar prints has never been
easier, or more accessible!
Understanding the basics—Watts, Amps, and Volts:
• Wattage (W) is how much power your plotter uses overall.
• Amps (A) are the current flowing through your system.
• Volts (V) are the pressure pushing that current through.
Here's a simple formula that ties them all together:

Watts (W) = Volts (V) × Amps (A)
So, if you know two of them, you can easily find out the third!

Calculating and Applying:
Step 1: Check Your Plotter’s Specs
The easiest way to start is by looking at the label or manual for your pen
plotter. Most devices will tell you:
• Input voltage (usually in volts, like 12V or 24V)
• Power consumption (in watts, like 20W or 50W)
Let’s say your pen plotter is rated at 24V and uses 30W of power.
Step 2: Calculate the Amps
If you have the wattage and volts, you can calculate amps using the
formula:

Amps (A) = Volts (V) / Watts (W)
For example, if your plotter uses 30W and runs on 24V:

Amps (A) = 30�/ 24�= 1.25�
That means your plotter will draw 1.25 amps while running.
Step 3: Make Sure Your Solar Panel Can Handle It
Now, check your solar panel’s specs. Solar panels usually list their power
output in watts. Let’s say you have a 50W solar panel.
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The amps your panel can provide can be found using the same formula as
before, so if your solar panel is 50W and 24V:

Amps (A) = 50W / 24V = 2.08A
In this case, your panel can supply 2.08 amps, and your plotter uses 1.25
amps, so you’re in the clear—your solar panel can handle it!
I don’t know the specs!
If you can’t find the exact specs of your plotter or solar panel, here’s a
workaround:
• Look for an Online Calculator: There are tons of free wattage calculators

that let you input basic info like the type of device and get a good
estimate.

• Estimate Based on Similar Devices: Many small electronics like pen
plotters will have similar power consumption, so you can usually find
comparable models online to get a ballpark idea.

• For a pen plotter you can often find the specs on retail sites such as
Amazon! Check the item description carefully.

Final tips to avoid dropping cash on a volt reader:
• Monitor Plotter Performance: If your plotter starts acting slow or cutting

out, it might be because it’s not getting enough power. Try scaling back
the complexity of your designs or moving to peak sunlight hours.

• Use a Solar Charge Controller: These devices sit between your solar
panel and plotter and help regulate the energy flow. They can prevent
overcharging or under-powering your plotter.

• Stay Under the Solar Panel’s Max Output: Always aim to use less power
than the panel’s max wattage to give yourself a buffer. This will help
avoid energy drops when the sun isn’t as bright.
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GENERAL TROUBLESHOOTING
INKSCAPE SPECIFIC—CRASHES AND SO MUCH MORE
So, you’re having trouble with Inkscape. I promise you, you’re in good
company. As said before, it’s hardly the most intuitive software, and more to
the point, very prone to crashing. One might even suggest that having a
fear that if you look at Inkscape wrong, it will crash is both normal and
rational. While that may be true, we can also provide you with some helpful
tips for how to fix it when it does crash! Learn from my mistakes to
hopefully get the most out of this software.
Inkscape Not Opening or Crashing on Startup
Solution: This can happen due to corrupted preferences or installation files.
Try resetting Inkscape's preferences to default.

Inkscape Running Slow or Freezing
Solution: Inkscape can slow down if you’re working with very complex
images or have too many open documents.
• Close unnecessary documents or applications running in the background

to free up system resources.
• Go to Edit > Preferences > Input/Output > Autosave and disable

autosave or increase the autosave interval. Autosave can cause
temporary freezes if set too frequently.

• Optimize your file by reducing the number of nodes or simplifying
complex paths (Path > Simplify).

iDraw 2.0 Pen Plotter Not Connecting to Inkscape
Solution: If Inkscape is not detecting your iDraw 2.0 pen plotter, check the
following:
• Ensure that the plotter is properly connected to your computer via USB

and powered on.
• Make sure you've installed the correct driver for the iDraw 2.0 plotter.

You can usually find this on the manufacturer's website.
• In Inkscape, go to Extensions > Export > Plot and select your device. If

the device does not appear, try restarting both Inkscape and your
computer.
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The Plotter is Not Responding to Commands or Stopping Mid-Job
Solution: This could be due to a communication issue between Inkscape
and the iDraw 2.0 plotter.
• Check that your USB cable is secure and not damaged.
• Ensure your computer doesn’t go into sleep mode while plotting; adjust

your power settings if needed.
• Check the plotter’s firmware. Sometimes, updating to the latest firmware

can solve communication problems.

Incorrect Plotting or Skewed Designs
Solution: If your designs are not being plotted correctly or appear skewed:
• Check that your document properties match the plotting area of your

iDraw 2.0. Go to File > Document Properties and set the dimensions to
match your plotter’s work area.

• Ensure that the design is within the printable area and that no objects
are outside the boundaries.

• Inkscape sometimes converts text to paths incorrectly. Convert all text to
paths manually before sending to plot: Select Text > Path > Object to
Path.

Inkscape Crashing and Pen Plotter Continuing to Print
Solution: Stop the Pen Plotter Immediately
• Physically Stop the Plotter: Since the pen plotter is still operating on its

last command, the quickest way to stop it is to turn it off. Locate the
power switch on the plotter and turn it off to immediately stop the
printing process.

• Disconnect the USB Cable: If you can't find the power switch quickly or
prefer not to turn off the machine, disconnect the USB cable connecting
the plotter to your computer. This will stop communication between the
plotter and your computer, halting any further plotting commands.

Recover Inkscape on Your Computer, which may have hidden itself after the
crash
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• Reopen Inkscape: After stopping the plotter, try reopening Inkscape. If
Inkscape does not appear in the Start Menu or desktop shortcuts:

• Press Ctrl + Alt + Delete to open the Task Manager.
• Look for any running instances of Inkscape under the "Processes" tab. If

you find any, select them and click "End Task" to force close Inkscape.
• Check for Hidden or Minimized Windows: Sometimes, the application

may still be running but not visible. Use Alt + Tab to cycle through open
windows and see if Inkscape is running but hidden.

Prevent Future Crashes
• Avoid Closing the Control Window Mid-Print: The pen plotter control

window is essential for communication between Inkscape and the iDraw
2.0. Closing it abruptly interrupts this communication and may cause
crashes or unexpected behavior.

• Use the "Pause" Function Instead: If you need to stop or adjust the print
mid-process, use the “Pause” button in the control window. This will
temporarily halt the plotter’s actions without closing the control interface
or crashing Inkscape.

• Ensure Inkscape is Fully Updated: An outdated version of Inkscape or the
pen plotter plugin might have bugs or stability issues. Regularly check
for and install updates for both Inkscape and the plotter software.

Reinstall Inkscape if Necessary
If Inkscape becomes unresponsive or won't start after the crash, consider
reinstalling it:
• Go to Control Panel > Programs > Uninstall a Program and find Inkscape

in the list. Right-click and select "Uninstall."
• Download the latest version of Inkscape from the official website and

reinstall it.
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IDRAW SPECIFIC—PENS, INK, AND GENERAL MESSINESS
Using a pen plotter like the iDraw 2.0 can be a fun and creative experience,
but sometimes things don’t go quite as planned. Here are some common
issues you might encounter and how to solve them:
Pen is Too Close to the Paper
Issue: If the pen is too close to the paper, it might drag across the surface,
causing scratches or thicker lines than intended.
Solution: Adjust the pen height. Most pen plotters, including the iDraw 2.0,
allow you to adjust the pen height manually.
• Loosen the pen holder screw and gently lift the pen a bit higher.
• Ensure the pen tip barely touches the paper when in the down position.
• You can test this by manually lowering the pen using the plotter’s control

panel or software interface. Make small adjustments until the pen just
touches the paper without pressing hard.

Image Description: an SVG print of a
cowbird, the ink is blurry in places and
there are many lines connecting things
that should not be connected—this is an
example of a somewhat cool result of a
pen being too close to the paper before
running a print.

Pen is Too Far from the Paper
Issue: If the pen is too far from the
paper, it might not make contact
properly, resulting in faint lines or
gaps in the drawing.
Solution: Lower the pen height.
• Loosen the pen holder screw and

gently lower the pen closer to
the paper.

• Ensure it is close enough to
make contact without pressing
too hard.
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• Run a test plot to check that the pen draws consistently across the entire
drawing area.

Blotty Pens or Ink Spilling
Issue: Blotty pens or ink spills can occur when the pen releases too much
ink, causing spots or smudges on the paper.
Solution:
• Check Pen Quality: Make sure you're using pens that are suitable for

plotting. Some pens, like gel pens, might release too much ink. Consider
using fine-tip pens designed for plotters.

• Store Pens Properly: Store your pens tip-down in a cup to keep the ink
flowing smoothly, but avoid excessive ink buildup at the tip.

• Adjust Pen Pressure: Some pens might need a lighter touch. If your
plotter has an adjustable pen pressure setting, reduce the pressure to
see if it helps reduce blotting.

Skipped Lines or Incomplete Drawings
Issue: The plotter skips lines or does not complete the drawing, which
could be due to the pen not making consistent contact or mechanical
issues.
Solution:
• Check Pen Contact: Ensure the pen is properly positioned and not

wobbling in the holder.
• Lubricate the Plotter Mechanisms: Sometimes, skipped lines can occur

due to mechanical resistance. Lightly lubricate the plotter’s moving parts
(like the carriage rails) with a small amount of machine oil.

• Ensure Firmware is Updated: An outdated firmware might cause
unexpected behaviors. Check the manufacturer's website for the latest
updates.

Mechanical Noises or Jerky Movements
Issue: Unusual noises or jerky movements during plotting can be caused by
mechanical issues or obstructions.
Solution:
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• Check for Obstructions: Make sure there are no objects or debris
blocking the plotter’s moving parts.

• Inspect the Belt and Pulleys: Check the belt tension and pulley
alignment. The belt should be taut but not overly tight. If the belt is
loose or off-track, consult your user manual for instructions on adjusting
it.

• Lubricate Moving Parts: Regularly lubricate the moving parts, as
mentioned earlier, to ensure smooth operation.

Plotter Not Responding to Commands
Issue: The plotter does not start or respond to commands from its control
panel or connected software.
Solution:
• Check Power and Connections: Ensure the plotter is powered on and

properly connected to your computer or power source.
• Reset the Plotter: Turn off the plotter, wait for a few seconds, and then

turn it back on. This can sometimes resolve minor glitches.
• Firmware and Software Updates: Make sure both the plotter’s firmware

and any controlling software are up-to-date to avoid compatibility
issues.

Paper Shifts During Plotting
Issue: If the paper moves or shifts while the plotter is working, it can ruin
your design.
Solution:
• Secure the Paper: Remember to use the magnets on the plotter surface

to keep the paper in place!
• Check for a Flat Surface: Ensure the plotter is on a flat, stable surface

with nothing obstructing the stand. Any wobbling or tilting can cause the
paper to move.

Pen not preforming well?
Issue: The pen isn’t drawing effectively, or line quality is inconsistent.
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Solution:
• Check Pen Condition: Ensure that the pen being used is relatively new.

Older pens may not perform well due to worn-out tips or dried ink,
leading to inconsistent lines under the plotter's pressure.

• Replace as Needed: If the pen shows signs of wear or the ink flow is
irregular, replace it with a fresh pen to maintain optimal performance.

• Pressure Adjustment: If the issue persists, consider adjusting the pen
pressure settings on the plotter, as this can also impact drawing quality.



32



L A B G U I D E


